Some users are unable to add team members
Incident Report for Disctopia
Resolved
This incident has been resolved - A full address is needed when creating team members.
Posted Sep 05, 2021 - 19:45 UTC
Investigating
We are currently investigating the issue.
Posted Sep 05, 2021 - 13:42 UTC
This incident affected: Web Applications (play.disctopia.com).