There is a login problem on our apps with AppSumo
Incident Report for Disctopia
Resolved
This incident has been resolved.
Posted Sep 04, 2021 - 19:38 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 03, 2021 - 19:21 UTC
Investigating
We are currently investigating this issue.
Posted Sep 03, 2021 - 19:20 UTC
This incident affected: Web Applications (play.disctopia.com).